Hírek | Archívum | Fórum | IRC | Pegasos | Efika | MorphOS | RSS


 - Fórumok - Regisztráció - Keresés - Statisztika - Szabályzat - amigaspirit.hu fórum
forum.pegasos.hu / Linux PPC / Debian Etch tapasztalatok
Szerző Üzenet
neongod
Tag

# Elküldve: 2007. Jún. 12. 11:03 - Szerkesztve: neongod


Feltettem Debian Etch-et, mindennel meg vagyok elegedve, egy dolgot leszamitva. A net csak a bejelentkezes utan eled fel es akkor is alapbol a gigabittel probalkozik.
Van gnomeban ilyen taskbarban csucsulo network switcher wizard. Az sem tunik teljesen funkcionalisnak. Pl. kivalasztom, hogy eth2 legyen a default akkor jo lesz, de reboot után hiába marad kiválasztva az eth2, nem megy a net. Olyankor atkapcsol eth1-re majd vissza eth2-re es megjavul..

/etc/network/interfaces -ben csak eth2 van megadva az alabbiak szerint:
iface eth2 inet dhcp
auto eth2

Valakinek barmi tapasztalata ilyen teren?

GK
Tag

# Elküldve: 2007. Jún. 12. 17:17


Van! Nekem is ezt csinalja! :D

(Valaki segithetne is...)

Chain|Q
Tag

# Elküldve: 2007. Jún. 12. 17:31 - Szerkesztve: charlie


1., regi OF-fel nekem folyamatosan cserelgette a network interfeszek sorrendjet. Ez elvileg workaroundolhato egy /etc/iftab fajl letrehozasaval, amiben fixen be lehet drotozni mac addressenkent az interfeszeket. esetleg le is lehet tiltani a gbitet, ha mas megoldas nincs. (Valahogy a modulok kozott, de ezt most nem vagom fejbol.)

2., a gyari 2.6.18-4-powerpc kernel nekem katasztrofalisan instabil volt, es lassu is. forditottam sajat 2.6.21.4-et, es megtaltosodott (erted, taltos paripa, hehe) a gep.

3., esetleg probalj meg felvinni egy ilyen sort az /etc/network/interfaces-be:

allow-hotplug eth2

4., a gnome network konfigjat felejtsuk el kerem, csak bohockodni jo

GK
Tag

# Elküldve: 2007. Jún. 13. 13:59 - Szerkesztve: gk


Nekem alapbol ez van az emlitett interfaces file-ban:

# The primary network interface
allow-hotplug eth2
iface eth2 inet dhcp
auto eth2


es igy eth0-ra (vagy 1-re? Sz'al a Gbitre) akar felmeni.

A kernellel kapcsolatos tanacsot meg koszi, majd megprobalkozom a ferditessel.

neongod
Tag

# Elküldve: 2007. Jún. 13. 14:19 - Szerkesztve: neongod


Csarli: az allow-hotplug eth2 ofcoz szerepel az interfaces-ben, alapbol ott volt nalam. Jelenleg azt csinaltam, hogy leszedtem a gnome-network-applet-manager framework-ot vagy mi a loszart, megnezem ugy.
Tovabba beallitottam a gigabit-et staticra valami fake cimre a via rhine-t meg dhcp-re. XFce-ben igy jonak tunik. Este meglatom gnome tovabbra is szetcseszi -e.

Mivel SBlive vs. alaplapi hangal is ugyan azt csinalta a debian, vagyis hogy minden rebootkor mashova detektalta oket (hol hw0,0, hol hw1,0.. stb.) Oda is kellett egy workaround. Egyelore ugy tunik, hogy a /etc/modprobe.d-be elhelyezett "sound" script az alias-okkal megoldotta a problemat. Tobb reboot utan ez is kiderul majd.

neongod
Tag

# Elküldve: 2007. Jún. 13. 18:42


no, ugy tunik valoban segitett a fentebb emlitett beallitas. Jo a halozat boot utan azonnal, aztan xfce-ben es gnome-ban is. Ugy latszik a gnome-network-framework-wizard-applet-tool volt a felelos.

A hang is jonak tunik SBLive-al. Az alabbit kellett hozza eszkozolni:

neongod@exile:~$ cat /etc/modprobe.d/sound
alias snd-card-0 snd-emu10k1
options snd-emu10k1 index=0
alias snd-card-1 snd-via82xx
options snd-via82xx index=1

 

Powered by bulletin board script miniBB™ © 2001-2021